public inbox for ~johnnyrichard/olang-devel@lists.sr.ht
 help / color / mirror / code / Atom feed
From: Carlos Maniero <carlos@maniero.me>
To: ~johnnyrichard/olang-devel@lists.sr.ht
Cc: Carlos Maniero <carlos@maniero.me>
Subject: [PATCH olang v1 0/5] Refactors to support semantics
Date: Wed, 23 Oct 2024 02:20:27 +0000 (UTC)	[thread overview]
Message-ID: <20241023022022.38379-1-carlos@maniero.me> (raw)

The semantics is an important part of a compiler but we have postpone
handling it so far. But the cost came, and we started to see some extra
responsibility on the codegen layer because of the lack of semantics.

This patchset does not address semantics per si, but it cover several
tech debts to start supporting it.

Carlos Maniero (5):
  type_checker: rename checker to type_checker
  ast: remove redundancy on ast_node base fields
  ast: unary: rename ast_unary.expr to ast_unary.operand
  ast: remove expr reference from return and var assign nodes
  semantics: add scope to all nodes

 src/ast.c                         |  8 ++--
 src/ast.h                         | 67 ++++++++++++++++---------------
 src/codegen_aarch64.c             |  2 +-
 src/codegen_x86_64.c              | 31 +++++++-------
 src/main.c                        |  2 +-
 src/pretty_print_ast.c            |  4 +-
 src/{checker.c => type_checker.c} | 18 ++++-----
 src/{checker.h => type_checker.h} |  0
 8 files changed, 67 insertions(+), 65 deletions(-)
 rename src/{checker.c => type_checker.c} (93%)
 rename src/{checker.h => type_checker.h} (100%)


base-commit: 2dbf9a9896e5778535bd3dc1d5069a762d3b94fa
-- 
2.46.1


             reply	other threads:[~2024-10-23  2:20 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-10-23  2:20 Carlos Maniero [this message]
2024-10-23  2:20 ` [PATCH olang v1 1/5] type_checker: rename checker to type_checker Carlos Maniero
2024-10-23  2:20 ` [PATCH olang v1 2/5] ast: remove redundancy on ast_node base fields Carlos Maniero
2024-10-23  2:20 ` [PATCH olang v1 3/5] ast: unary: rename ast_unary.expr to ast_unary.operand Carlos Maniero
2024-10-23  2:20 ` [PATCH olang v1 4/5] ast: remove expr reference from return and var assign nodes Carlos Maniero
2024-10-23  2:20 ` [PATCH olang v1 5/5] semantics: add scope to all nodes Carlos Maniero
2024-10-23  2:21   ` [olang/patches/.build.yml] build success builds.sr.ht
2024-10-23 17:36   ` [PATCH olang v1 5/5] semantics: add scope to all nodes Johnny Richard
2024-10-23 17:34 ` [PATCH olang v1 0/5] Refactors to support semantics Johnny Richard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20241023022022.38379-1-carlos@maniero.me \
    --to=carlos@maniero.me \
    --cc=~johnnyrichard/olang-devel@lists.sr.ht \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.johnnyrichard.com/olang.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox