public inbox for ~johnnyrichard/olang-devel@lists.sr.ht
 help / color / mirror / code / Atom feed
From: "Carlos Maniero" <carlos@maniero.me>
To: "Johnny Richard" <johnny@johnnyrichard.com>
Cc: <~johnnyrichard/olang-devel@lists.sr.ht>
Subject: Re: [PATCH olang 2/2] tests: add integration test setup
Date: Thu, 15 Feb 2024 23:27:00 -0300	[thread overview]
Message-ID: <CZ65CAVNEPLF.OFWGZUHBQA51@maniero.me> (raw)
In-Reply-To: <2fltgo6fnzgcnrmvi5akr7d5kc7qkrfsxaketlsdet4my5i6c2@hfozssfoes3o>

Thanks for the feedback, I'll answer some of you questions here. The
ones I didn't address here is because I just agree and the fix will be
sent on the next patchset.

> What is the motivation behind segregate integration tests from unit
> tests?

I might be dreaming at this point, but I know you kinda share the same
dream of making olang a self-hosted language. With this in mind, I think
it is a good idea to have these two levels of testing: unit tests will
test c-related stuff and implementation details, while integration tests
will test the compiler features by calling the compiler with a
*system()* call.

When we start to rewrite the compiler in olang, the unit tests may
change because we gonna change the design of the compiler to remove the
"c-accent". On the other hand, integration tests should not be touched
during the rewriting process because the features will stay the same.

> What do you think about the /linter-fix/ and /linter/ scan all files
> instead of introducing new targets with -all suffix?

I like to have small targets that are composed this brings more
flexibility to my workflow, but I have no strong opinion with this one.
I'll change they in the reviewed patchset.

> nitpick: I cannot see a big benefit of adding an underscore for this
> property neither for methods.  I understand you want to communicate that
> it should not be access by other sources.
> 
> What do you think about making these "_" properties and functions
> static?

I love the idea.

> What is binary_loc? Does it means location or path?

Yeah! that name sucks. It is the compilation result binary path.
WDYT about rename it to *program_path*?

And sorry about the previous empty email, I've no idea what happened.

  parent reply	other threads:[~2024-02-16  2:27 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-15 16:21 [PATCH olang 0/2] Add integration tests Carlos Maniero
2024-02-15 16:21 ` [PATCH olang 1/2] tests: add munit testing framework file Carlos Maniero
2024-02-15 16:21 ` [PATCH olang 2/2] tests: add integration test setup Carlos Maniero
2024-02-15 16:27   ` [olang/patches/.build.yml] build success builds.sr.ht
2024-02-15 22:21   ` [PATCH olang 2/2] tests: add integration test setup Johnny Richard
2024-02-15 22:07     ` Carlos Maniero
2024-02-16  2:27     ` Carlos Maniero [this message]
2024-02-16  8:17       ` Johnny Richard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CZ65CAVNEPLF.OFWGZUHBQA51@maniero.me \
    --to=carlos@maniero.me \
    --cc=johnny@johnnyrichard.com \
    --cc=~johnnyrichard/olang-devel@lists.sr.ht \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox

	https://git.johnnyrichard.com/olang.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox