* [PATCH olang v1 1/5] type_checker: rename checker to type_checker
@ 2024-10-23 2:19 Carlos Maniero
2024-10-23 2:22 ` Carlos Maniero
0 siblings, 1 reply; 3+ messages in thread
From: Carlos Maniero @ 2024-10-23 2:19 UTC (permalink / raw)
To: ~johnnyrichard/olang-devel; +Cc: Carlos Maniero
To void adding all the semantics concerns into a single module, we are
renaming the checker file to type_checker.
Other checkers will be introduced as needed.
Signed-off-by: Carlos Maniero <carlos@maniero.me>
---
src/main.c | 2 +-
src/{checker.c => type_checker.c} | 2 +-
src/{checker.h => type_checker.h} | 0
3 files changed, 2 insertions(+), 2 deletions(-)
rename src/{checker.c => type_checker.c} (99%)
rename src/{checker.h => type_checker.h} (100%)
diff --git a/src/main.c b/src/main.c
index 685d8ce..c99ccfc 100644
--- a/src/main.c
+++ b/src/main.c
@@ -22,7 +22,6 @@
#include <string.h>
#include "arena.h"
-#include "checker.h"
#include "cli.h"
#include "codegen_aarch64.h"
#include "codegen_x86_64.h"
@@ -30,6 +29,7 @@
#include "parser.h"
#include "pretty_print_ast.h"
#include "string_view.h"
+#include "type_checker.h"
// TODO: find a better solution to define the arena capacity
#define ARENA_CAPACITY (1024 * 1024)
diff --git a/src/checker.c b/src/type_checker.c
similarity index 99%
rename from src/checker.c
rename to src/type_checker.c
index 02341cc..b426349 100644
--- a/src/checker.c
+++ b/src/type_checker.c
@@ -14,7 +14,7 @@
* You should have received a copy of the GNU General Public License
* along with this program. If not, see <https://www.gnu.org/licenses/>.
*/
-#include "checker.h"
+#include "type_checker.h"
#include "scope.h"
#include <assert.h>
#include <errno.h>
diff --git a/src/checker.h b/src/type_checker.h
similarity index 100%
rename from src/checker.h
rename to src/type_checker.h
--
2.46.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH olang v1 1/5] type_checker: rename checker to type_checker
2024-10-23 2:19 [PATCH olang v1 1/5] type_checker: rename checker to type_checker Carlos Maniero
@ 2024-10-23 2:22 ` Carlos Maniero
0 siblings, 0 replies; 3+ messages in thread
From: Carlos Maniero @ 2024-10-23 2:22 UTC (permalink / raw)
To: Carlos Maniero, ~johnnyrichard/olang-devel
I messed again. You can ignore this individual email, the entire
patchset was sent in another thread.
^ permalink raw reply [flat|nested] 3+ messages in thread
* [PATCH olang v1 1/5] type_checker: rename checker to type_checker
2024-10-23 2:20 [PATCH olang v1 0/5] Refactors to support semantics Carlos Maniero
@ 2024-10-23 2:20 ` Carlos Maniero
0 siblings, 0 replies; 3+ messages in thread
From: Carlos Maniero @ 2024-10-23 2:20 UTC (permalink / raw)
To: ~johnnyrichard/olang-devel; +Cc: Carlos Maniero
To void adding all the semantics concerns into a single module, we are
renaming the checker file to type_checker.
Other checkers will be introduced as needed.
Signed-off-by: Carlos Maniero <carlos@maniero.me>
---
src/main.c | 2 +-
src/{checker.c => type_checker.c} | 2 +-
src/{checker.h => type_checker.h} | 0
3 files changed, 2 insertions(+), 2 deletions(-)
rename src/{checker.c => type_checker.c} (99%)
rename src/{checker.h => type_checker.h} (100%)
diff --git a/src/main.c b/src/main.c
index 685d8ce..c99ccfc 100644
--- a/src/main.c
+++ b/src/main.c
@@ -22,7 +22,6 @@
#include <string.h>
#include "arena.h"
-#include "checker.h"
#include "cli.h"
#include "codegen_aarch64.h"
#include "codegen_x86_64.h"
@@ -30,6 +29,7 @@
#include "parser.h"
#include "pretty_print_ast.h"
#include "string_view.h"
+#include "type_checker.h"
// TODO: find a better solution to define the arena capacity
#define ARENA_CAPACITY (1024 * 1024)
diff --git a/src/checker.c b/src/type_checker.c
similarity index 99%
rename from src/checker.c
rename to src/type_checker.c
index 02341cc..b426349 100644
--- a/src/checker.c
+++ b/src/type_checker.c
@@ -14,7 +14,7 @@
* You should have received a copy of the GNU General Public License
* along with this program. If not, see <https://www.gnu.org/licenses/>.
*/
-#include "checker.h"
+#include "type_checker.h"
#include "scope.h"
#include <assert.h>
#include <errno.h>
diff --git a/src/checker.h b/src/type_checker.h
similarity index 100%
rename from src/checker.h
rename to src/type_checker.h
--
2.46.1
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2024-10-23 2:22 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-10-23 2:19 [PATCH olang v1 1/5] type_checker: rename checker to type_checker Carlos Maniero
2024-10-23 2:22 ` Carlos Maniero
2024-10-23 2:20 [PATCH olang v1 0/5] Refactors to support semantics Carlos Maniero
2024-10-23 2:20 ` [PATCH olang v1 1/5] type_checker: rename checker to type_checker Carlos Maniero
Code repositories for project(s) associated with this public inbox
https://git.johnnyrichard.com/olang.git
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox